Установка FOSUserBundle на Symfony

Идем по инструкции:

пытаемся прогнать первый запрос из директории проекта

composer require friendsofsymfony/user-bundle "~1.3"

НО для симфони 3.2 это не работает: пишется ошибка

./composer.json has been updated
Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

Problem 1
 - Conclusion: remove symfony/symfony v3.2.2
 - Conclusion: don't install symfony/symfony v3.2.2
 - friendsofsymfony/user-bundle v1.3.7 requires symfony/security-bundle ~2.3 -> satisfiable by symfony/security-bundle[v2.3.0, v2.3.1, v2.3.10, v2.3.11, v2.3.12, v2.3.13, v2.3.14, v2.3.15, v2.3.16, v2.3.17, v2.3.18, v2.3.19, v2.3.2, v2.3.20, v2.3.21, v2.3.22, v2.3.23, v2.3.24, v2.3.25, v2.3.26, v2.3.27, v2.3.28, v2.3.29, v2.3.3, v2.3.30, v2.3.31, v2.3.32, v2.3.33, v2.3.34, v2.3.35, v2.3.36, v2.3.37, v2.3.38, v2.3.39, v2.3.4, v2.3.40, v2.3.41, v2.3.42, v2.3.5, v2.3.6, v2.3.7, v2.3.8, v2.3.9, v2.4.0, v2.4.1, v2.4.10, v2.4.2, v2.4.3, v2.4.4, v2.4.5, v2.4.6, v2.4.7, v2.4.8, v2.4.9, v2.5.0, v2.5.1, v2.5.10, v2.5.11, v2.5.12, v2.5.2, v2.5.3, v2.5.4, v2.5.5, v2.5.6, v2.5.7, v2.5.8, v2.5.9, v2.6.0, v2.6.1, v2.6.10, v2.6.11, v2.6.12, v2.6.13, v2.6.2, v2.6.3, v2.6.4, v2.6.5, v2.6.6, v2.6.7, v2.6.8, v2.6.9, v2.7.0, v2.7.1, v2.7.10, v2.7.11, v2.7.12, v2.7.13, v2.7.14, v2.7.15, v2.7.16, v2.7.17, v2.7.18, v2.7.19, v2.7.2, v2.7.20, v2.7.21, v2.7.22, v2.7.23, v2.7.24, v2.7.3, v2.7.4, v2.7.5, v2.7.6, v2.7.7, v2.7.8, v2.7.9, v2.8.0, v2.8.1, v2.8.10, v2.8.11, v2.8.12, v2.8.13, v2.8.14, v2.8.15, v2.8.16, v2.8.17, v2.8.2, v2.8.3, v2.8.4, v2.8.5, v2.8.6, v2.8.7, v2.8.8, v2.8.9].
 - friendsofsymfony/user-bundle v1.3.0 requires symfony/security-bundle 2.1.* -> satisfiable by symfony/security-bundle[v2.1.0, v2.1.1, v2.1.10, v2.1.11, v2.1.12, v2.1.13, v2.1.2, v2.1.3, v2.1.4, v2.1.5, v2.1.6, v2.1.7, v2.1.8, v2.1.9].
 - friendsofsymfony/user-bundle v1.3.1 requires symfony/security-bundle >=2.1,<2.3-dev -> satisfiable by symfony/security-bundle[v2.1.0, v2.1.1, v2.1.10, v2.1.11, v2.1.12, v2.1.13, v2.1.2, v2.1.3, v2.1.4, v2.1.5, v2.1.6, v2.1.7, v2.1.8, v2.1.9, v2.2.0, v2.2.1, v2.2.10, v2.2.11, v2.2.2, v2.2.3, v2.2.4, v2.2.5, v2.2.6, v2.2.7, v2.2.8, v2.2.9].
 - friendsofsymfony/user-bundle v1.3.2 requires symfony/security-bundle ~2.1 -> satisfiable by symfony/security-bundle[v2.1.0, v2.1.1, v2.1.10, v2.1.11, v2.1.12, v2.1.13, v2.1.2, v2.1.3, v2.1.4, v2.1.5, v2.1.6, v2.1.7, v2.1.8, v2.1.9, v2.2.0, v2.2.1, v2.2.10, v2.2.11, v2.2.2, v2.2.3, v2.2.4, v2.2.5, v2.2.6, v2.2.7, v2.2.8, v2.2.9, v2.3.0, v2.3.1, v2.3.10, v2.3.11, v2.3.12, v2.3.13, v2.3.14, v2.3.15, v2.3.16, v2.3.17, v2.3.18, v2.3.19, v2.3.2, v2.3.20, v2.3.21, v2.3.22, v2.3.23, v2.3.24, v2.3.25, v2.3.26, v2.3.27, v2.3.28, v2.3.29, v2.3.3, v2.3.30, v2.3.31, v2.3.32, v2.3.33, v2.3.34, v2.3.35, v2.3.36, v2.3.37, v2.3.38, v2.3.39, v2.3.4, v2.3.40, v2.3.41, v2.3.42, v2.3.5, v2.3.6, v2.3.7, v2.3.8, v2.3.9, v2.4.0, v2.4.1, v2.4.10, v2.4.2, v2.4.3, v2.4.4, v2.4.5, v2.4.6, v2.4.7, v2.4.8, v2.4.9, v2.5.0, v2.5.1, v2.5.10, v2.5.11, v2.5.12, v2.5.2, v2.5.3, v2.5.4, v2.5.5, v2.5.6, v2.5.7, v2.5.8, v2.5.9, v2.6.0, v2.6.1, v2.6.10, v2.6.11, v2.6.12, v2.6.13, v2.6.2, v2.6.3, v2.6.4, v2.6.5, v2.6.6, v2.6.7, v2.6.8, v2.6.9, v2.7.0, v2.7.1, v2.7.10, v2.7.11, v2.7.12, v2.7.13, v2.7.14, v2.7.15, v2.7.16, v2.7.17, v2.7.18, v2.7.19, v2.7.2, v2.7.20, v2.7.21, v2.7.22, v2.7.23, v2.7.24, v2.7.3, v2.7.4, v2.7.5, v2.7.6, v2.7.7, v2.7.8, v2.7.9, v2.8.0, v2.8.1, v2.8.10, v2.8.11, v2.8.12, v2.8.13, v2.8.14, v2.8.15, v2.8.16, v2.8.17, v2.8.2, v2.8.3, v2.8.4, v2.8.5, v2.8.6, v2.8.7, v2.8.8, v2.8.9].
 - friendsofsymfony/user-bundle v1.3.3 requires symfony/security-bundle ~2.1 -> satisfiable by symfony/security-bundle[v2.1.0, v2.1.1, v2.1.10, v2.1.11, v2.1.12, v2.1.13, v2.1.2, v2.1.3, v2.1.4, v2.1.5, v2.1.6, v2.1.7, v2.1.8, v2.1.9, v2.2.0, v2.2.1, v2.2.10, v2.2.11, v2.2.2, v2.2.3, v2.2.4, v2.2.5, v2.2.6, v2.2.7, v2.2.8, v2.2.9, v2.3.0, v2.3.1, v2.3.10, v2.3.11, v2.3.12, v2.3.13, v2.3.14, v2.3.15, v2.3.16, v2.3.17, v2.3.18, v2.3.19, v2.3.2, v2.3.20, v2.3.21, v2.3.22, v2.3.23, v2.3.24, v2.3.25, v2.3.26, v2.3.27, v2.3.28, v2.3.29, v2.3.3, v2.3.30, v2.3.31, v2.3.32, v2.3.33, v2.3.34, v2.3.35, v2.3.36, v2.3.37, v2.3.38, v2.3.39, v2.3.4, v2.3.40, v2.3.41, v2.3.42, v2.3.5, v2.3.6, v2.3.7, v2.3.8, v2.3.9, v2.4.0, v2.4.1, v2.4.10, v2.4.2, v2.4.3, v2.4.4, v2.4.5, v2.4.6, v2.4.7, v2.4.8, v2.4.9, v2.5.0, v2.5.1, v2.5.10, v2.5.11, v2.5.12, v2.5.2, v2.5.3, v2.5.4, v2.5.5, v2.5.6, v2.5.7, v2.5.8, v2.5.9, v2.6.0, v2.6.1, v2.6.10, v2.6.11, v2.6.12, v2.6.13, v2.6.2, v2.6.3, v2.6.4, v2.6.5, v2.6.6, v2.6.7, v2.6.8, v2.6.9, v2.7.0, v2.7.1, v2.7.10, v2.7.11, v2.7.12, v2.7.13, v2.7.14, v2.7.15, v2.7.16, v2.7.17, v2.7.18, v2.7.19, v2.7.2, v2.7.20, v2.7.21, v2.7.22, v2.7.23, v2.7.24, v2.7.3, v2.7.4, v2.7.5, v2.7.6, v2.7.7, v2.7.8, v2.7.9, v2.8.0, v2.8.1, v2.8.10, v2.8.11, v2.8.12, v2.8.13, v2.8.14, v2.8.15, v2.8.16, v2.8.17, v2.8.2, v2.8.3, v2.8.4, v2.8.5, v2.8.6, v2.8.7, v2.8.8, v2.8.9].
 - friendsofsymfony/user-bundle v1.3.4 requires symfony/security-bundle ~2.1 -> satisfiable by symfony/security-bundle[v2.1.0, v2.1.1, v2.1.10, v2.1.11, v2.1.12, v2.1.13, v2.1.2, v2.1.3, v2.1.4, v2.1.5, v2.1.6, v2.1.7, v2.1.8, v2.1.9, v2.2.0, v2.2.1, v2.2.10, v2.2.11, v2.2.2, v2.2.3, v2.2.4, v2.2.5, v2.2.6, v2.2.7, v2.2.8, v2.2.9, v2.3.0, v2.3.1, v2.3.10, v2.3.11, v2.3.12, v2.3.13, v2.3.14, v2.3.15, v2.3.16, v2.3.17, v2.3.18, v2.3.19, v2.3.2, v2.3.20, v2.3.21, v2.3.22, v2.3.23, v2.3.24, v2.3.25, v2.3.26, v2.3.27, v2.3.28, v2.3.29, v2.3.3, v2.3.30, v2.3.31, v2.3.32, v2.3.33, v2.3.34, v2.3.35, v2.3.36, v2.3.37, v2.3.38, v2.3.39, v2.3.4, v2.3.40, v2.3.41, v2.3.42, v2.3.5, v2.3.6, v2.3.7, v2.3.8, v2.3.9, v2.4.0, v2.4.1, v2.4.10, v2.4.2, v2.4.3, v2.4.4, v2.4.5, v2.4.6, v2.4.7, v2.4.8, v2.4.9, v2.5.0, v2.5.1, v2.5.10, v2.5.11, v2.5.12, v2.5.2, v2.5.3, v2.5.4, v2.5.5, v2.5.6, v2.5.7, v2.5.8, v2.5.9, v2.6.0, v2.6.1, v2.6.10, v2.6.11, v2.6.12, v2.6.13, v2.6.2, v2.6.3, v2.6.4, v2.6.5, v2.6.6, v2.6.7, v2.6.8, v2.6.9, v2.7.0, v2.7.1, v2.7.10, v2.7.11, v2.7.12, v2.7.13, v2.7.14, v2.7.15, v2.7.16, v2.7.17, v2.7.18, v2.7.19, v2.7.2, v2.7.20, v2.7.21, v2.7.22, v2.7.23, v2.7.24, v2.7.3, v2.7.4, v2.7.5, v2.7.6, v2.7.7, v2.7.8, v2.7.9, v2.8.0, v2.8.1, v2.8.10, v2.8.11, v2.8.12, v2.8.13, v2.8.14, v2.8.15, v2.8.16, v2.8.17, v2.8.2, v2.8.3, v2.8.4, v2.8.5, v2.8.6, v2.8.7, v2.8.8, v2.8.9].
 - friendsofsymfony/user-bundle v1.3.5 requires symfony/security-bundle ~2.1 -> satisfiable by symfony/security-bundle[v2.1.0, v2.1.1, v2.1.10, v2.1.11, v2.1.12, v2.1.13, v2.1.2, v2.1.3, v2.1.4, v2.1.5, v2.1.6, v2.1.7, v2.1.8, v2.1.9, v2.2.0, v2.2.1, v2.2.10, v2.2.11, v2.2.2, v2.2.3, v2.2.4, v2.2.5, v2.2.6, v2.2.7, v2.2.8, v2.2.9, v2.3.0, v2.3.1, v2.3.10, v2.3.11, v2.3.12, v2.3.13, v2.3.14, v2.3.15, v2.3.16, v2.3.17, v2.3.18, v2.3.19, v2.3.2, v2.3.20, v2.3.21, v2.3.22, v2.3.23, v2.3.24, v2.3.25, v2.3.26, v2.3.27, v2.3.28, v2.3.29, v2.3.3, v2.3.30, v2.3.31, v2.3.32, v2.3.33, v2.3.34, v2.3.35, v2.3.36, v2.3.37, v2.3.38, v2.3.39, v2.3.4, v2.3.40, v2.3.41, v2.3.42, v2.3.5, v2.3.6, v2.3.7, v2.3.8, v2.3.9, v2.4.0, v2.4.1, v2.4.10, v2.4.2, v2.4.3, v2.4.4, v2.4.5, v2.4.6, v2.4.7, v2.4.8, v2.4.9, v2.5.0, v2.5.1, v2.5.10, v2.5.11, v2.5.12, v2.5.2, v2.5.3, v2.5.4, v2.5.5, v2.5.6, v2.5.7, v2.5.8, v2.5.9, v2.6.0, v2.6.1, v2.6.10, v2.6.11, v2.6.12, v2.6.13, v2.6.2, v2.6.3, v2.6.4, v2.6.5, v2.6.6, v2.6.7, v2.6.8, v2.6.9, v2.7.0, v2.7.1, v2.7.10, v2.7.11, v2.7.12, v2.7.13, v2.7.14, v2.7.15, v2.7.16, v2.7.17, v2.7.18, v2.7.19, v2.7.2, v2.7.20, v2.7.21, v2.7.22, v2.7.23, v2.7.24, v2.7.3, v2.7.4, v2.7.5, v2.7.6, v2.7.7, v2.7.8, v2.7.9, v2.8.0, v2.8.1, v2.8.10, v2.8.11, v2.8.12, v2.8.13, v2.8.14, v2.8.15, v2.8.16, v2.8.17, v2.8.2, v2.8.3, v2.8.4, v2.8.5, v2.8.6, v2.8.7, v2.8.8, v2.8.9].
 - friendsofsymfony/user-bundle v1.3.6 requires symfony/security-bundle ~2.1 -> satisfiable by symfony/security-bundle[v2.1.0, v2.1.1, v2.1.10, v2.1.11, v2.1.12, v2.1.13, v2.1.2, v2.1.3, v2.1.4, v2.1.5, v2.1.6, v2.1.7, v2.1.8, v2.1.9, v2.2.0, v2.2.1, v2.2.10, v2.2.11, v2.2.2, v2.2.3, v2.2.4, v2.2.5, v2.2.6, v2.2.7, v2.2.8, v2.2.9, v2.3.0, v2.3.1, v2.3.10, v2.3.11, v2.3.12, v2.3.13, v2.3.14, v2.3.15, v2.3.16, v2.3.17, v2.3.18, v2.3.19, v2.3.2, v2.3.20, v2.3.21, v2.3.22, v2.3.23, v2.3.24, v2.3.25, v2.3.26, v2.3.27, v2.3.28, v2.3.29, v2.3.3, v2.3.30, v2.3.31, v2.3.32, v2.3.33, v2.3.34, v2.3.35, v2.3.36, v2.3.37, v2.3.38, v2.3.39, v2.3.4, v2.3.40, v2.3.41, v2.3.42, v2.3.5, v2.3.6, v2.3.7, v2.3.8, v2.3.9, v2.4.0, v2.4.1, v2.4.10, v2.4.2, v2.4.3, v2.4.4, v2.4.5, v2.4.6, v2.4.7, v2.4.8, v2.4.9, v2.5.0, v2.5.1, v2.5.10, v2.5.11, v2.5.12, v2.5.2, v2.5.3, v2.5.4, v2.5.5, v2.5.6, v2.5.7, v2.5.8, v2.5.9, v2.6.0, v2.6.1, v2.6.10, v2.6.11, v2.6.12, v2.6.13, v2.6.2, v2.6.3, v2.6.4, v2.6.5, v2.6.6, v2.6.7, v2.6.8, v2.6.9, v2.7.0, v2.7.1, v2.7.10, v2.7.11, v2.7.12, v2.7.13, v2.7.14, v2.7.15, v2.7.16, v2.7.17, v2.7.18, v2.7.19, v2.7.2, v2.7.20, v2.7.21, v2.7.22, v2.7.23, v2.7.24, v2.7.3, v2.7.4, v2.7.5, v2.7.6, v2.7.7, v2.7.8, v2.7.9, v2.8.0, v2.8.1, v2.8.10, v2.8.11, v2.8.12, v2.8.13, v2.8.14, v2.8.15, v2.8.16, v2.8.17, v2.8.2, v2.8.3, v2.8.4, v2.8.5, v2.8.6, v2.8.7, v2.8.8, v2.8.9].
 - don't install symfony/security-bundle v2.3.0|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.3.1|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.3.10|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.3.11|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.3.12|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.3.13|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.3.14|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.3.15|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.3.16|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.3.17|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.3.18|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.3.19|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.3.2|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.3.20|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.3.21|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.3.22|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.3.23|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.3.24|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.3.25|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.3.26|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.3.27|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.3.28|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.3.29|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.3.3|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.3.30|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.3.31|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.3.32|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.3.33|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.3.34|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.3.35|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.3.36|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.3.37|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.3.38|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.3.39|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.3.4|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.3.40|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.3.41|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.3.42|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.3.5|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.3.6|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.3.7|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.3.8|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.3.9|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.4.0|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.4.1|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.4.10|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.4.2|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.4.3|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.4.4|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.4.5|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.4.6|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.4.7|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.4.8|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.4.9|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.5.0|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.5.1|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.5.10|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.5.11|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.5.12|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.5.2|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.5.3|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.5.4|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.5.5|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.5.6|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.5.7|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.5.8|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.5.9|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.6.0|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.6.1|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.6.10|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.6.11|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.6.12|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.6.13|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.6.2|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.6.3|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.6.4|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.6.5|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.6.6|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.6.7|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.6.8|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.6.9|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.7.0|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.7.1|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.7.10|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.7.11|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.7.12|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.7.13|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.7.14|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.7.15|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.7.16|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.7.17|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.7.18|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.7.19|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.7.2|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.7.20|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.7.21|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.7.22|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.7.23|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.7.24|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.7.3|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.7.4|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.7.5|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.7.6|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.7.7|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.7.8|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.7.9|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.8.0|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.8.1|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.8.10|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.8.11|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.8.12|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.8.13|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.8.14|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.8.15|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.8.16|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.8.17|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.8.2|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.8.3|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.8.4|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.8.5|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.8.6|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.8.7|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.8.8|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.8.9|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.1.0|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.1.1|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.1.10|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.1.11|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.1.12|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.1.13|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.1.2|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.1.3|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.1.4|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.1.5|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.1.6|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.1.7|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.1.8|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.1.9|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.2.0|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.2.1|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.2.10|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.2.11|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.2.2|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.2.3|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.2.4|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.2.5|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.2.6|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.2.7|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.2.8|don't install symfony/symfony v3.2.2
 - don't install symfony/security-bundle v2.2.9|don't install symfony/symfony v3.2.2
 - Installation request for symfony/symfony (locked at v3.2.2, required as 3.2.*) -> satisfiable by symfony/symfony[v3.2.2].
 - Installation request for friendsofsymfony/user-bundle ~1.3 -> satisfiable by friendsofsymfony/user-bundle[v1.3.0, v1.3.1, v1.3.2, v1.3.3, v1.3.4, v1.3.5, v1.3.6, v1.3.7].


Installation failed, reverting ./composer.json to its original content.

Поэтому запускаем эту команду

composer require friendsofsymfony/user-bundle "~2.0@dev"

ее ответ:

./composer.json has been updated
Loading composer repositories with package information
Updating dependencies (including require-dev)
 - Updating friendsofsymfony/user-bundle dev-master (6b8828b => 6a12083)
 Checking out 6a12083d0f6b53ca312021b15277d92be571cbe6

Writing lock file
Generating autoload files
> Incenteev\ParameterHandler\ScriptHandler::buildParameters
Updating the "app/config/parameters.yml" file
> Sensio\Bundle\DistributionBundle\Composer\ScriptHandler::buildBootstrap
> Sensio\Bundle\DistributionBundle\Composer\ScriptHandler::clearCache

// Clearing the cache for the dev environment with debug 
 // true


 [OK] Cache for the "dev" environment (debug=true) was successfully cleared. 


> Sensio\Bundle\DistributionBundle\Composer\ScriptHandler::installAssets

Trying to install assets as relative symbolic links.

--- ------------------- ------------------ 
 Bundle Method / Error 
 --- ------------------- ------------------ 
 ✔ AppBundle relative symlink 
 ✔ SonataCoreBundle relative symlink 
 ✔ SonataAdminBundle relative symlink 
 --- ------------------- ------------------


 [OK] All assets were successfully installed. 


> Sensio\Bundle\DistributionBundle\Composer\ScriptHandler::installRequirementsFile
> Sensio\Bundle\DistributionBundle\Composer\ScriptHandler::prepareDeploymentTarget

Дальше действуем по инструкции

Прописываем в кернеле

<?php
// app/AppKernel.php

public function registerBundles()
{
 $bundles = array(
 // ...
 new FOS\UserBundle\FOSUserBundle(),
 // ...
 );
}

Создаем Этити для USER

<?php
// src/AppBundle/Entity/User.php

namespace AppBundle\Entity;

use FOS\UserBundle\Entity\User as BaseUser;
use Doctrine\ORM\Mapping as ORM;

/**
 * @ORM\Entity
 * @ORM\Table(name="fos_user")
 */
class User extends BaseUser
{
 /**
 * @ORM\Id
 * @ORM\Column(type="integer")
 * @ORM\GeneratedValue(strategy="AUTO")
 */
 protected $id;

public function __construct()
 {
 parent::__construct();
 // your own logic
 }
}

Теперь редактируем application’s security.yml

Добавляем это

# app/config/security.yml
security:
 encoders:
 FOS\UserBundle\Model\UserInterface: bcrypt

role_hierarchy:
 ROLE_ADMIN: ROLE_USER
 ROLE_SUPER_ADMIN: ROLE_ADMIN

providers:
 fos_userbundle:
 id: fos_user.user_provider.username

firewalls:
 main:
 pattern: ^/
 form_login:
 provider: fos_userbundle
 csrf_provider: security.csrf.token_manager # Use form.csrf_provider instead for Symfony <2.4
 logout: true
 anonymous: true

access_control:
 - { path: ^/login$, role: IS_AUTHENTICATED_ANONYMOUSLY }
 - { path: ^/register, role: IS_AUTHENTICATED_ANONYMOUSLY }
 - { path: ^/resetting, role: IS_AUTHENTICATED_ANONYMOUSLY }
 - { path: ^/admin/, role: ROLE_ADMIN }

Теперь добавляем в config.yml

# app/config/config.yml
fos_user:
 db_driver: orm # other valid values are 'mongodb', 'couchdb' and 'propel'
 firewall_name: main
 user_class: AppBundle\Entity\User

Имопортируем FOSUserBundle routing files

# app/config/routing.yml
fos_user_security:
 resource: "@FOSUserBundle/Resources/config/routing/security.xml"

fos_user_profile:
 resource: "@FOSUserBundle/Resources/config/routing/profile.xml"
 prefix: /profile

fos_user_register:
 resource: "@FOSUserBundle/Resources/config/routing/registration.xml"
 prefix: /register

fos_user_resetting:
 resource: "@FOSUserBundle/Resources/config/routing/resetting.xml"
 prefix: /resetting

fos_user_change_password:
 resource: "@FOSUserBundle/Resources/config/routing/change_password.xml"
 prefix: /profile

Дальше делаем апдейт базы и получаем ошибку

Could not open input file: app/console
macbookPro:concert nik$ php bin/console doctrine:schema:update --force


 [Symfony\Component\Config\Definition\Exception\InvalidConfigurationException] 
 Unrecognized option "csrf_provider" under "security.firewalls.main.form_login"
заходим файл securety.yml
комментим строчку csrf_provider и добаляем
csrf_token_generator: security.csrf.token_manager

Получается такое:

...
 main:
   pattern: ^/
   form_login:
   provider: fos_userbundle
   csrf_token_generator: security.csrf.token_manager
   # csrf_provider: security.csrf.token_manager # Use form.csrf_provider instead for Symfony <2.4
...

Запускаем скрипт еще раз -опять ошибка но уже другая

macbookPro:concert nik$ php bin/console doctrine:schema:update --force
 [Symfony\Component\Config\Definition\Exception\InvalidConfigurationException] 
 The child node "from_email" at path "fos_user" must be configured. 
 

 

добавляем в config в секцию fos_user
...
fos_user:
 db_driver: orm # other valid values are 'mongodb', 'couchdb' and 'propel'
 firewall_name: main
 user_class: AppBundle\Entity\User

from_email:
 address: youemail@email.com
 sender_name: You

Запускаем и опять ошибка

macbookPro:concert nik$ php bin/console doctrine:schema:update --force
PHP Fatal error: Class 'FOS\UserBundle\Entity\User' not found in /Users/nik/Documents/sites/concert/src/AppBundle/Entity/User.php on line 14

в файле entity User

use FOS\UserBundle\Entity\User as BaseUser;
меняем на
use FOS\UserBundle\Model\User as BaseUser;

Прогоняем скрипт

macbookPro:concert nik$ php bin/console doctrine:schema:update —force
Updating database schema…
Database schema updated successfully! «1» query was executed

 

Все получилось!